反代WordPress前端开启HTTPS后,部分JS和CSS无法加载的解决办法

最近尝试了用前端服务器反代后端服务器上的WordPress网站,出于效率考虑,采用了后端http,前端https这样着组合,不过却发现部分JS和CSS一直无法加载,提示Mixed Content和the content must be served over HTTPS等报错,经过一番折腾后还是未果。

到了最后,实在无法解决,就求助他人,才得知WordPress对这方面有限制,反代的话前后端都必须是HTTPS,所以还是老老实实的前后段都开启HTTPS吧。

 

当然此教程是针对反代WordPress网站这种情况,其他类型的网站可能没有这个限制。

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注